[CMAKE]
[reactos.git] / dll / win32 / user32 / CMakeLists.txt
index e61d6cf..1be8800 100644 (file)
@@ -39,7 +39,6 @@ list(APPEND SOURCE
     misc/usrapihk.c
     misc/winhelp.c
     misc/winsta.c
-    misc/wsprintf.c
     windows/accel.c
     windows/caret.c
     windows/class.c
@@ -64,11 +63,8 @@ list(APPEND SOURCE
     windows/text.c
     windows/window.c
     windows/winpos.c
-    user32_stubs.c
     user32.rc
     ${CMAKE_CURRENT_BINARY_DIR}/user32.def)
-    
-set_source_files_properties(user32.def PROPERTIES EXTERNAL_OBJECT TRUE)
 
 add_library(user32 SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/user32_user32.h.gch
@@ -77,12 +73,12 @@ add_library(user32 SHARED
 set_module_type(user32 win32dll)
 
 target_link_libraries(user32
+    user32_wsprintf
     wine
     win32ksys
     ${PSEH_LIB})
-                      
+
 add_pch(user32 ${CMAKE_CURRENT_SOURCE_DIR}/include/user32.h ${SOURCE})
 add_importlibs(user32 gdi32 advapi32 imm32 msvcrt kernel32 ntdll)
-add_cab_target(user32 1)
+add_cd_file(TARGET user32 DESTINATION reactos/system32 FOR all)
 add_importlib_target(user32.spec)
-