[CMAKE]
[reactos.git] / dll / win32 / user32 / CMakeLists.txt
index 2fb3d3a..6394d31 100644 (file)
@@ -1,6 +1,8 @@
 
 set_unicode()
 
+spec2def(user32.dll user32.pspec)
+
 add_definitions(-D_DLL -D__USE_CRTIMP)
 
 include_directories(
@@ -63,7 +65,10 @@ list(APPEND SOURCE
     windows/window.c
     windows/winpos.c
     user32_stubs.c
-    user32.rc)
+    user32.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/user32.def)
+    
+set_source_files_properties(user32.def PROPERTIES EXTERNAL_OBJECT TRUE)
 
 add_library(user32 SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/user32_user32.h.gch
@@ -72,11 +77,12 @@ add_library(user32 SHARED
 set_module_type(user32 win32dll)
 
 target_link_libraries(user32
-    ${CMAKE_CURRENT_SOURCE_DIR}/user32.def
     wine
     win32ksys
-    pseh)
+    ${PSEH_LIB})
                       
 add_pch(user32 ${CMAKE_CURRENT_SOURCE_DIR}/include/user32.h ${SOURCE})
 add_importlibs(user32 gdi32 advapi32 imm32 kernel32 ntdll)
-add_livecd_target(user32 reactos/system32)
+add_cab_target(user32 1)
+add_importlib_target(${CMAKE_CURRENT_BINARY_DIR}/user32.def)
+