[USP10] Sync with Wine Staging 3.3. CORE-14434
[reactos.git] / dll / win32 / usp10 / CMakeLists.txt
index 2cf15aa..25b76c5 100644 (file)
@@ -1,10 +1,11 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 add_definitions(-D__WINESRC__)
 spec2def(usp10.dll usp10.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     bidi.c
+    bracket.c
     breaking.c
     indic.c
     indicsyllable.c
@@ -14,7 +15,7 @@ list(APPEND SOURCE
     shape.c
     shaping.c
     usp10.c
-    usp10_internal.h
+    precomp.h
     ${CMAKE_CURRENT_BINARY_DIR}/usp10_stubs.c)
 
 add_library(usp10 SHARED
@@ -24,5 +25,5 @@ add_library(usp10 SHARED
 set_module_type(usp10 win32dll)
 target_link_libraries(usp10 wine)
 add_importlibs(usp10 advapi32 user32 gdi32 msvcrt kernel32 ntdll)
-add_pch(usp10 usp10_internal.h SOURCE)
+add_pch(usp10 precomp.h SOURCE)
 add_cd_file(TARGET usp10 DESTINATION reactos/system32 FOR all)