[CMAKE]
[reactos.git] / dll / win32 / usp10 / CMakeLists.txt
index 0e5a2f5..d6cea79 100644 (file)
@@ -2,20 +2,20 @@
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 add_definitions(-D__WINESRC__)
 
-spec2def(usp10 ${CMAKE_CURRENT_SOURCE_DIR}/usp10.spec ${CMAKE_CURRENT_BINARY_DIR}/usp10.def)
+spec2def(usp10.dll usp10.spec)
 
 add_library(usp10 SHARED
     bidi.c
     usp10.c
     mirror.c
     shape.c
-    shaping.c)
+    shaping.c
+    ${CMAKE_CURRENT_BINARY_DIR}/usp10.def)
 
 set_module_type(usp10 win32dll)
 
-target_link_libraries(usp10
-    ${CMAKE_CURRENT_BINARY_DIR}/usp10.def
-    wine)
+target_link_libraries(usp10 wine)
 
 add_importlibs(usp10 gdi32 kernel32 ntdll)
-add_dependencies(usp10 usp10_def)
+
+add_cab_target(usp10 1)