* Sync up to trunk head (r64921).
[reactos.git] / dll / win32 / usp10 / CMakeLists.txt
index b9af555..dd87e1e 100644 (file)
@@ -5,6 +5,7 @@ spec2def(usp10.dll usp10.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     bidi.c
+    bracket.c
     breaking.c
     indic.c
     indicsyllable.c
@@ -14,11 +15,15 @@ list(APPEND SOURCE
     shape.c
     shaping.c
     usp10.c
-    ${CMAKE_CURRENT_BINARY_DIR}/usp10_stubs.c
+    usp10_internal.h
+    ${CMAKE_CURRENT_BINARY_DIR}/usp10_stubs.c)
+
+add_library(usp10 SHARED
+    ${SOURCE}
     ${CMAKE_CURRENT_BINARY_DIR}/usp10.def)
 
-add_library(usp10 SHARED ${SOURCE})
 set_module_type(usp10 win32dll)
 target_link_libraries(usp10 wine)
 add_importlibs(usp10 advapi32 user32 gdi32 msvcrt kernel32 ntdll)
+add_pch(usp10 usp10_internal.h SOURCE)
 add_cd_file(TARGET usp10 DESTINATION reactos/system32 FOR all)