[CMAKE]
[reactos.git] / dll / win32 / uxtheme / CMakeLists.txt
index 78cf67c..45fe043 100644 (file)
@@ -1,10 +1,11 @@
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 add_definitions(-D__WINESRC__)
+set_rc_compiler()
 
-spec2def(uxtheme ${CMAKE_CURRENT_SOURCE_DIR}/uxtheme.spec ${CMAKE_CURRENT_BINARY_DIR}/uxtheme.def)
+spec2def(uxtheme.dll uxtheme.spec)
 
-add_library(uxtheme SHARED
+list(APPEND SOURCE
     buffer.c
     draw.c
     main.c
@@ -14,14 +15,17 @@ add_library(uxtheme SHARED
     stylemap.c
     system.c
     uxini.c
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/uxtheme_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/uxtheme.def)
+
+add_library(uxtheme SHARED ${SOURCE})
 
 set_module_type(uxtheme win32dll)
 
-target_link_libraries(uxtheme
-    ${CMAKE_CURRENT_BINARY_DIR}/uxtheme.def
-    wine)
+target_link_libraries(uxtheme wine)
+
+add_importlibs(uxtheme user32 advapi32 gdi32 msimg32 msvcrt kernel32 ntdll)
 
-add_importlibs(uxtheme user32 advapi32 gdi32 msimg32 kernel32 ntdll)
-add_dependencies(uxtheme uxtheme_def)
-add_livecd_target(uxtheme reactos/system32)
+add_cd_file(TARGET uxtheme DESTINATION reactos/system32)
+add_importlib_target(uxtheme.spec)