* Sync up to trunk HEAD (r62286).
[reactos.git] / dll / win32 / wbemprox / CMakeLists.txt
index a9ec2bb..ede7f42 100644 (file)
@@ -19,13 +19,18 @@ list(APPEND SOURCE
     table.c
     wbemlocator.c
     wql.tab.c
+    wbemprox_private.h)
+
+add_library(wbemprox SHARED
+    ${SOURCE}
     guid.c
+    wbemprox.rc
     ${CMAKE_CURRENT_BINARY_DIR}/wbemprox.def)
 
-add_library(wbemprox SHARED ${SOURCE} wbemprox.rc)
 set_source_files_properties(wbemprox.rc PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/wbemprox.rgs)
 set_module_type(wbemprox win32dll)
 target_link_libraries(wbemprox uuid wine)
 add_importlibs(wbemprox iphlpapi dxgi oleaut32 advapi32 user32 gdi32 version msvcrt kernel32 ntdll)
 add_dependencies(wbemprox d3d_idl_headers)
+add_pch(wbemprox wbemprox_private.h SOURCE)
 add_cd_file(TARGET wbemprox DESTINATION reactos/system32/wbem FOR all)