Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / dll / win32 / wldap32 / CMakeLists.txt
diff --git a/dll/win32/wldap32/CMakeLists.txt b/dll/win32/wldap32/CMakeLists.txt
new file mode 100644 (file)
index 0000000..0b7ef75
--- /dev/null
@@ -0,0 +1,39 @@
+
+add_definitions(-D__WINESRC__)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
+spec2def(wldap32.dll wldap32.spec ADD_IMPORTLIB)
+
+list(APPEND SOURCE
+    add.c
+    bind.c
+    compare.c
+    control.c
+    delete.c
+    dn.c
+    error.c
+    extended.c
+    init.c
+    main.c
+    misc.c
+    modify.c
+    modrdn.c
+    option.c
+    page.c
+    parse.c
+    rename.c
+    search.c
+    value.c
+    winldap_private.h
+    ${CMAKE_CURRENT_BINARY_DIR}/wldap32_stubs.c)
+
+add_library(wldap32 SHARED
+    ${SOURCE}
+    ber.c
+    wldap32.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/wldap32.def)
+
+set_module_type(wldap32 win32dll)
+target_link_libraries(wldap32 wine)
+add_importlibs(wldap32 user32 msvcrt kernel32 ntdll)
+add_pch(wldap32 winldap_private.h SOURCE)
+add_cd_file(TARGET wldap32 DESTINATION reactos/system32 FOR all)