* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / wldap32 / CMakeLists.txt
index 6f987c2..6ef3ca9 100644 (file)
@@ -5,7 +5,6 @@ spec2def(wldap32.dll wldap32.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     add.c
-    ber.c
     bind.c
     compare.c
     control.c
@@ -24,11 +23,17 @@ list(APPEND SOURCE
     rename.c
     search.c
     value.c
-    ${CMAKE_CURRENT_BINARY_DIR}/wldap32_stubs.c
+    winldap_private.h
+    ${CMAKE_CURRENT_BINARY_DIR}/wldap32_stubs.c)
+
+add_library(wldap32 SHARED
+    ${SOURCE}
+    ber.c
+    wldap32.rc
     ${CMAKE_CURRENT_BINARY_DIR}/wldap32.def)
 
-add_library(wldap32 SHARED ${SOURCE} wldap32.rc)
 set_module_type(wldap32 win32dll)
 target_link_libraries(wldap32 wine)
 add_importlibs(wldap32 user32 msvcrt kernel32 ntdll)
+add_pch(wldap32 winldap_private.h SOURCE)
 add_cd_file(TARGET wldap32 DESTINATION reactos/system32 FOR all)