[CMAKE]
[reactos.git] / dll / win32 / wldap32 / CMakeLists.txt
index 9115ccd..c97f5e4 100644 (file)
@@ -2,9 +2,10 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+set_rc_compiler()
 spec2def(wldap32.dll wldap32.spec)
 
-add_library(wldap32 SHARED
+list(APPEND SOURCE
     add.c
     ber.c
     bind.c
@@ -26,12 +27,15 @@ add_library(wldap32 SHARED
     search.c
     value.c
     wldap32.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/wldap32_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/wldap32.def)
 
+add_library(wldap32 SHARED ${SOURCE})
+
 set_module_type(wldap32 win32dll)
 
 target_link_libraries(wldap32 wine)
 
-add_importlibs(wldap32 user32 kernel32 ntdll)
-
-add_cab_target(wldap32 1)
+add_importlibs(wldap32 user32 msvcrt kernel32 ntdll)
+add_importlib_target(wldap32.spec)
+add_cd_file(TARGET wldap32 DESTINATION reactos/system32 FOR all)