* Sync up to trunk head (r64829).
[reactos.git] / dll / win32 / ws2_32_new / CMakeLists.txt
index 3689850..7754c96 100644 (file)
@@ -1,12 +1,11 @@
 
 add_definitions(-DLE)
+spec2def(ws2_32_new.dll ws2_32.spec)
 
 include_directories(
     inc
     ${REACTOS_SOURCE_DIR}/include/reactos/winsock)
 
-spec2def(ws2_32_new.dll ws2_32.spec)
-
 list(APPEND SOURCE
     src/addrconv.c
     src/addrinfo.c
@@ -44,12 +43,15 @@ list(APPEND SOURCE
     src/sputil.c
     src/startup.c
     src/wsautil.c
+    inc/ws2_32.h)
+
+add_library(ws2_32_new SHARED
+    ${SOURCE}
     ws2_32.rc
     ${CMAKE_CURRENT_BINARY_DIR}/ws2_32_new.def)
 
-add_library(ws2_32_new SHARED ${SOURCE})
 set_module_type(ws2_32_new win32dll)
 add_importlibs(ws2_32_new user32 advapi32 dnsapi ws2help msvcrt kernel32 ntdll)
-add_pch(ws2_32_new inc/ws2_32.h)
+add_pch(ws2_32_new inc/ws2_32.h SOURCE)
 target_link_libraries(ws2_32_new wine)
 add_cd_file(TARGET ws2_32_new DESTINATION reactos/system32 FOR all)