[CMAKE]
[reactos.git] / dll / win32 / ws2help / CMakeLists.txt
index 2dee236..51f0c99 100644 (file)
@@ -1,18 +1,19 @@
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/winsock)
 
-spec2def(ws2help ${CMAKE_CURRENT_SOURCE_DIR}/ws2help.spec ${CMAKE_CURRENT_BINARY_DIR}/ws2help.def)
+spec2def(ws2help.dll ws2help.spec)
 
-add_library(ws2help SHARED
+list(APPEND SOURCE
     apc.c
     context.c
     dllmain.c
     handle.c
-    notify.c)
+    notify.c
+    ${CMAKE_CURRENT_BINARY_DIR}/ws2help.def)
 
-set_module_type(ws2help win32dll)
+add_library(ws2help SHARED ${SOURCE})
 
-target_link_libraries(ws2help ${CMAKE_CURRENT_BINARY_DIR}/ws2help.def)
-add_importlibs(ws2help advapi32 ws2_32 kernel32 ntdll)
-add_dependencies(ws2help ws2help_def)
-add_livecd_target(ws2help reactos/system32)
+set_module_type(ws2help win32dll)
+add_importlibs(ws2help advapi32 ws2_32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET ws2help DESTINATION reactos/system32)
+add_importlib_target(ws2help.spec)