* Sync up to trunk head (r64921).
[reactos.git] / dll / win32 / ws2help / CMakeLists.txt
index 7aaf650..d041224 100644 (file)
@@ -1,6 +1,5 @@
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/winsock)
-
 spec2def(ws2help.dll ws2help.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -9,11 +8,13 @@ list(APPEND SOURCE
     dllmain.c
     handle.c
     notify.c
+    precomp.h)
+
+add_library(ws2help SHARED
+    ${SOURCE}
     ${CMAKE_CURRENT_BINARY_DIR}/ws2help.def)
 
-add_library(ws2help SHARED ${SOURCE})
 set_module_type(ws2help win32dll)
 add_importlibs(ws2help advapi32 ws2_32 msvcrt kernel32 ntdll)
-add_pch(ws2help precomp.h)
+add_pch(ws2help precomp.h SOURCE)
 add_cd_file(TARGET ws2help DESTINATION reactos/system32 FOR all)
-