Sync with trunk r63743.
[reactos.git] / dll / win32 / wshirda / CMakeLists.txt
index 7c9f59c..ea11099 100644 (file)
@@ -1,13 +1,14 @@
 
-set_unicode()
 
-spec2def(wshirda ${CMAKE_CURRENT_SOURCE_DIR}/wshirda.spec ${CMAKE_CURRENT_BINARY_DIR}/wshirda.def)
+spec2def(wshirda.dll wshirda.spec)
 
-add_library(wshirda SHARED wshirda.c wshirda.rc)
+list(APPEND SOURCE
+    wshirda.c
+    wshirda.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/wshirda.def)
 
-set_module_type(wshirda win32dll)
+add_library(wshirda SHARED ${SOURCE})
 
-target_link_libraries(wshirda ${CMAKE_CURRENT_BINARY_DIR}/wshirda.def)
-add_importlibs(wshirda ws2_32 kernel32 ntdll)
-add_dependencies(wshirda wshirda_def)
-add_livecd_target(wshirda reactos/system32)
+set_module_type(wshirda win32dll UNICODE)
+add_importlibs(wshirda ws2_32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET wshirda DESTINATION reactos/system32 FOR all)