Sync with trunk r63174.
[reactos.git] / dll / win32 / wshirda / CMakeLists.txt
index a03f4d3..ea11099 100644 (file)
@@ -1,14 +1,14 @@
 
-set_unicode()
 
-add_library(wshirda SHARED wshirda.c wshirda.rc wshirda.def)
+spec2def(wshirda.dll wshirda.spec)
 
-if(NOT MSVC)
-    set_source_files_properties(wshirda.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+list(APPEND SOURCE
+    wshirda.c
+    wshirda.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/wshirda.def)
 
-set_module_type(wshirda win32dll)
+add_library(wshirda SHARED ${SOURCE})
 
-add_importlibs(wshirda ws2_32 kernel32 ntdll)
-
-add_cab_target(wshirda 1)
+set_module_type(wshirda win32dll UNICODE)
+add_importlibs(wshirda ws2_32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET wshirda DESTINATION reactos/system32 FOR all)