[CMAKE]
[reactos.git] / dll / win32 / wshtcpip / CMakeLists.txt
index 875c4df..1f1664f 100644 (file)
@@ -5,14 +5,16 @@ include_directories(${REACTOS_SOURCE_DIR}/lib/tdilib)
 
 spec2def(wshtcpip.dll wshtcpip.spec)
 
-add_library(wshtcpip SHARED wshtcpip.c wshtcpip.rc
+list(APPEND SOURCE
+    wshtcpip.c
+    wshtcpip.rc
     ${CMAKE_CURRENT_BINARY_DIR}/wshtcpip.def)
 
+add_library(wshtcpip SHARED ${SOURCE})
+
 set_entrypoint(wshtcpip 0)
 
 target_link_libraries(wshtcpip tdilib)
-
 add_importlibs(wshtcpip ws2_32 kernel32 ntdll)
-add_dependencies(wshtcpip psdk buildno_header)
-
-add_livecd_target(wshtcpip reactos/system32)
\ No newline at end of file
+add_dependencies(wshtcpip psdk)
+add_cd_file(TARGET wshtcpip DESTINATION reactos/system32)