[CMAKE]
[reactos.git] / dll / win32 / wshtcpip / CMakeLists.txt
index 28cc35d..bea0689 100644 (file)
@@ -3,17 +3,18 @@ set_unicode()
 
 include_directories(${REACTOS_SOURCE_DIR}/lib/tdilib)
 
-add_library(wshtcpip SHARED wshtcpip.c wshtcpip.rc wshtcpip.def)
+spec2def(wshtcpip.dll wshtcpip.spec)
 
-if(NOT MSVC)
-    set_source_files_properties(wshtcpip.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+list(APPEND SOURCE
+    wshtcpip.c
+    wshtcpip.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/wshtcpip.def)
+
+add_library(wshtcpip SHARED ${SOURCE})
 
 set_entrypoint(wshtcpip 0)
 
 target_link_libraries(wshtcpip tdilib)
-
 add_importlibs(wshtcpip ws2_32 kernel32 ntdll)
-add_dependencies(wshtcpip psdk buildno_header)
-
-add_cab_target(wshtcpip 1)
\ No newline at end of file
+add_dependencies(wshtcpip psdk)
+add_cd_file(TARGET wshtcpip DESTINATION reactos/system32 FOR all)