try fix build
[reactos.git] / dll / win32 / wuapi / CMakeLists.txt
index 3d6809f..33ceb54 100644 (file)
@@ -4,26 +4,26 @@ add_definitions(-D__WINESRC__)
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(
+    ${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(wuapi ${CMAKE_CURRENT_SOURCE_DIR}/wuapi.spec ${CMAKE_CURRENT_BINARY_DIR}/wuapi.def)
 
-add_library(wuapi SHARED
+spec2def(wuapi.dll wuapi.spec)
+
+list(APPEND SOURCE
     downloader.c
     installer.c
     main.c
     regsvr.c
     searcher.c
     session.c
-    updates.c)
-
-set_module_type(wuapi win32dll)
+    updates.c
+    ${CMAKE_CURRENT_BINARY_DIR}/wuapi.def)
 
-target_link_libraries(wuapi
-    ${CMAKE_CURRENT_BINARY_DIR}/wuapi.def
-    wine
-    uuid)
+add_library(wuapi SHARED ${SOURCE})
 
-add_importlibs(wuapi ole32 advapi32 kernel32 ntdll)
-add_dependencies(wuapi wuapi_def)
-add_livecd_target(wuapi reactos/system32)
+set_module_type(wuapi win32dll)
+target_link_libraries(wuapi uuid wine wuapi_idl_header)
+add_importlibs(wuapi ole32 advapi32 msvcrt kernel32 ntdll)
+add_cab_target(wuapi 1)
+add_dependencies(wuapi wuapi_idl_header) 
\ No newline at end of file