Sync with trunk r62754.
[reactos.git] / dll / win32 / wuapi / CMakeLists.txt
index 795b9b6..bef091a 100644 (file)
@@ -1,29 +1,32 @@
 
-add_definitions(-D__WINESRC__)
-
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
+add_definitions(
+    -D__WINESRC__
+    -DCOM_NO_WINDOWS_H)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+spec2def(wuapi.dll wuapi.spec)
 
-spec2def(wuapi ${CMAKE_CURRENT_SOURCE_DIR}/wuapi.spec ${CMAKE_CURRENT_BINARY_DIR}/wuapi.def)
-
-add_library(wuapi SHARED
+list(APPEND SOURCE
     downloader.c
     installer.c
     main.c
-    regsvr.c
     searcher.c
     session.c
-    updates.c)
+    systeminfo.c
+    updates.c
+    wuapi_private.h)
 
-set_module_type(wuapi win32dll)
+add_typelib(wuapi_tlb.idl)
+set_source_files_properties(wuapi.rc PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/wuapi_tlb.tlb)
 
-target_link_libraries(wuapi
-    ${CMAKE_CURRENT_BINARY_DIR}/wuapi.def
-    wine
-    uuid)
+add_library(wuapi SHARED
+    ${SOURCE}
+    wuapi.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/wuapi.def)
 
-add_importlibs(wuapi ole32 advapi32 kernel32 ntdll)
-add_dependencies(wuapi wuapi_def)
-add_cab_target(wuapi 1)
+set_module_type(wuapi win32dll)
+target_link_libraries(wuapi uuid wine wuguid)
+add_importlibs(wuapi msvcrt kernel32 ntdll)
+add_dependencies(wuapi stdole2) # wuapi_tlb.tlb needs stdole2.tlb
+add_pch(wuapi wuapi_private.h SOURCE)
+add_cd_file(TARGET wuapi DESTINATION reactos/system32 FOR all)