[CMAKE]
[reactos.git] / dll / win32 / xinput1_1 / CMakeLists.txt
index 98134c9..8b8e354 100644 (file)
@@ -2,12 +2,15 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(xinput1_1 ${CMAKE_CURRENT_SOURCE_DIR}/xinput1_1.spec ${CMAKE_CURRENT_BINARY_DIR}/xinput1_1.def)
+spec2def(xinput1_1.dll xinput1_1.spec)
 
-add_library(xinput1_1 SHARED xinput1_1_main.c version.rc)
+list(APPEND SOURCE
+    xinput1_1_main.c
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/xinput1_1.def)
 
-set_module_type(xinput1_1 win32dll)
+add_library(xinput1_1 SHARED ${SOURCE})
 
-target_link_libraries(xinput1_1 ${CMAKE_CURRENT_BINARY_DIR}/xinput1_1.def)
-add_importlibs(xinput1_1 kernel32)
-add_dependencies(xinput1_1 xinput1_1_def)
+set_module_type(xinput1_1 win32dll)
+add_importlibs(xinput1_1 msvcrt kernel32 xinput1_3)
+add_cd_file(TARGET xinput1_1 DESTINATION reactos/system32 FOR all)