[CMAKE]
[reactos.git] / dll / win32 / xinput1_3 / CMakeLists.txt
index d4ce8eb..6af5a89 100644 (file)
@@ -2,16 +2,17 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-add_library(xinput1_3 SHARED xinput1_3_main.c version.rc xinput1_3.def)
+spec2def(xinput1_3.dll xinput1_3.spec)
 
-if(NOT MSVC)
-    set_source_files_properties(xinput1_3.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+list(APPEND SOURCE
+    xinput1_3_main.c
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/xinput1_3.def)
 
-set_module_type(xinput1_3 win32dll)
+add_library(xinput1_3 SHARED ${SOURCE})
 
+add_importlib_target(xinput1_3.spec)
+set_module_type(xinput1_3 win32dll)
 target_link_libraries(xinput1_3 wine)
-
 add_importlibs(xinput1_3 msvcrt kernel32 ntdll)
-
-add_cab_target(xinput1_3 1)
+add_cd_file(TARGET xinput1_3 DESTINATION reactos/system32)