[CMAKE]
[reactos.git] / dll / win32 / xinput1_3 / CMakeLists.txt
index 463928f..9d37edd 100644 (file)
@@ -2,14 +2,17 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(xinput1_3 ${CMAKE_CURRENT_SOURCE_DIR}/xinput1_3.spec ${CMAKE_CURRENT_BINARY_DIR}/xinput1_3.def)
+spec2def(xinput1_3.dll xinput1_3.spec)
 
-add_library(xinput1_3 SHARED xinput1_3_main.c version.rc)
+list(APPEND SOURCE
+    xinput1_3_main.c
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/xinput1_3.def)
 
-set_module_type(xinput1_3 win32dll)
-
-target_link_libraries(xinput1_3
-    ${CMAKE_CURRENT_BINARY_DIR}/xinput1_3.def
-    wine)
+add_library(xinput1_3 SHARED ${SOURCE})
 
-add_dependencies(xinput1_3 xinput1_3_def psdk)
+add_importlib_target(xinput1_3.spec)
+set_module_type(xinput1_3 win32dll)
+target_link_libraries(xinput1_3 wine)
+add_importlibs(xinput1_3 msvcrt kernel32 ntdll)
+add_cd_file(TARGET xinput1_3 DESTINATION reactos/system32 FOR all)