[CMAKE]
[reactos.git] / dll / win32 / xmllite / CMakeLists.txt
index f94df56..33dc4cb 100644 (file)
@@ -2,17 +2,20 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(xmllite ${CMAKE_CURRENT_SOURCE_DIR}/xmllite.spec ${CMAKE_CURRENT_BINARY_DIR}/xmllite.def)
+spec2def(xmllite.dll xmllite.spec)
 
-add_library(xmllite SHARED reader.c xmllite_main.c)
+list(APPEND SOURCE
+    reader.c
+    xmllite_main.c
+    ${CMAKE_CURRENT_BINARY_DIR}/xmllite_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/xmllite.def)
 
-set_module_type(xmllite win32dll)
+add_library(xmllite SHARED ${SOURCE})
 
-target_link_libraries(xmllite
-    ${CMAKE_CURRENT_BINARY_DIR}/xmllite.def
-    wine)
+set_module_type(xmllite win32dll)
 
-add_importlibs(xmllite kernel32 ntdll)
+target_link_libraries(xmllite wine)
 
-add_dependencies(xmllite xmllite_def)
-add_livecd_target(xmllite reactos/system32)
+add_importlibs(xmllite msvcrt kernel32 ntdll)
+add_importlib_target(xmllite.spec)
+add_cab_target(xmllite 1)