[CMAKE]
[reactos.git] / dll / win32 / xmllite / CMakeLists.txt
index a8a0d4f..855cd3a 100644 (file)
@@ -4,14 +4,19 @@ include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(xmllite.dll xmllite.spec)
 
-add_library(xmllite SHARED reader.c xmllite_main.c ${CMAKE_CURRENT_BINARY_DIR}/xmllite.def)
+list(APPEND SOURCE
+    reader.c
+    xmllite_main.c
+    #${REACTOS_BINARY_DIR}/include/psdk/xmllite_i.c
+    ${CMAKE_CURRENT_BINARY_DIR}/xmllite_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/xmllite.def)
 
-set_module_type(xmllite win32dll)
-
-target_link_libraries(xmllite
-    wine)
+add_library(xmllite SHARED ${SOURCE})
 
-add_importlibs(xmllite kernel32 ntdll)
+set_module_type(xmllite win32dll)
 
+target_link_libraries(xmllite wine uuid)
 
-add_cab_target(xmllite 1)
+add_importlibs(xmllite msvcrt kernel32 ntdll)
+add_importlib_target(xmllite.spec)
+add_cd_file(TARGET xmllite DESTINATION reactos/system32 FOR all)