[CMAKE]
[reactos.git] / drivers / base / bootvid / CMakeLists.txt
index 7a9b0ee..1f90098 100644 (file)
@@ -1,9 +1,9 @@
 
+spec2def(bootvid.dll bootvid.spec)
 
-
-spec2def(bootvid ${CMAKE_CURRENT_SOURCE_DIR}/bootvid.spec ${CMAKE_CURRENT_BINARY_DIR}/bootvid.def)
-
-list(APPEND SOURCE bootvid.rc)
+list(APPEND SOURCE
+    bootvid.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/bootvid.def)
 
 if(ARCH MATCHES i386 OR ARCH MATCHES amd64)
 list(APPEND SOURCE
@@ -21,11 +21,10 @@ add_library(bootvid SHARED ${CMAKE_CURRENT_BINARY_DIR}/bootvid_precomp.h.gch ${S
 set_target_properties(bootvid PROPERTIES LINK_FLAGS "-Wl,-entry,0 -Wl,--image-base,0x00010000")
 
 target_link_libraries(bootvid
-    ${CMAKE_CURRENT_BINARY_DIR}/bootvid.def
     -lntoskrnl
     -lhal)
 
 add_pch(bootvid ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_dependencies(bootvid bootvid_def psdk buildno_header bugcodes)
+add_dependencies(bootvid psdk buildno_header bugcodes)
 add_minicd_target(bootvid reactos bootvid.dll)
-add_minicd_target(bootvid reactos/system32)
\ No newline at end of file
+add_cab_target(bootvid 1)
\ No newline at end of file