[CMAKE]
[reactos.git] / drivers / base / bootvid / CMakeLists.txt
index 33b67af..3c23c82 100644 (file)
@@ -1,9 +1,9 @@
 
+spec2def(bootvid.dll bootvid.spec)
 
-
-spec2def(bootvid ${CMAKE_CURRENT_SOURCE_DIR}/bootvid.spec ${CMAKE_CURRENT_BINARY_DIR}/bootvid.def)
-
-list(APPEND SOURCE bootvid.rc)
+list(APPEND SOURCE
+    bootvid.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/bootvid.def)
 
 if(ARCH MATCHES i386 OR ARCH MATCHES amd64)
 list(APPEND SOURCE
@@ -18,14 +18,12 @@ endif(ARCH MATCHES i386 OR ARCH MATCHES amd64)
 
 add_library(bootvid SHARED ${CMAKE_CURRENT_BINARY_DIR}/bootvid_precomp.h.gch ${SOURCE})
 
-set_target_properties(bootvid PROPERTIES LINK_FLAGS "-Wl,-entry,0 -Wl,--image-base,0x00010000")
-
-target_link_libraries(bootvid
-    ${CMAKE_CURRENT_BINARY_DIR}/bootvid.def
-    -lntoskrnl
-    -lhal)
+set_entrypoint(bootvid 0)
+set_subsystem(bootvid native)
+set_image_base(bootvid 0x00010000)
 
+add_importlibs(bootvid ntoskrnl hal)
 add_pch(bootvid ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_dependencies(bootvid bootvid_def psdk buildno_header bugcodes)
-add_minicd_target(bootvid reactos bootvid.dll)
-add_livecd_target(bootvid reactos/system32)
\ No newline at end of file
+add_dependencies(bootvid psdk bugcodes)
+add_cd_file(TARGET bootvid DESTINATION reactos/system32 NO_CAB FOR all)
+add_importlib_target(bootvid.spec)