Sync with trunk r58740.
[reactos.git] / drivers / bus / isapnp / CMakeLists.txt
index 9fc61d9..ea6eea4 100644 (file)
@@ -6,9 +6,7 @@ add_library(isapnp SHARED
     hardware.c
     isapnp.rc)
 
-set_target_properties(isapnp PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--exclude-all-symbols -Wl,--subsystem,native" SUFFIX ".sys")
-
+set_module_type(isapnp kernelmodedriver)
 add_importlibs(isapnp ntoskrnl hal)
-add_dependencies(isapnp psdk bugcodes buildno_header)
-add_minicd_target(isapnp reactos isapnp.sys)
-add_livecd_target(isapnp reactos/system32/drivers)
\ No newline at end of file
+add_pch(isapnp isapnp.h)
+add_cd_file(TARGET isapnp DESTINATION reactos/system32/drivers NO_CAB FOR all)