- Update to r53061
[reactos.git] / drivers / bus / isapnp / CMakeLists.txt
index f3155be..ea6eea4 100644 (file)
@@ -1,6 +1,4 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES>")
-
 add_library(isapnp SHARED
     isapnp.c
     pdo.c
@@ -8,10 +6,7 @@ add_library(isapnp SHARED
     hardware.c
     isapnp.rc)
 
-set_target_properties(isapnp PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--exclude-all-symbols -Wl,--subsystem,native" SUFFIX ".sys")
-
-target_link_libraries(isapnp
-    -lntoskrnl
-    -lhal)
-
-add_dependencies(isapnp psdk bugcodes)
+set_module_type(isapnp kernelmodedriver)
+add_importlibs(isapnp ntoskrnl hal)
+add_pch(isapnp isapnp.h)
+add_cd_file(TARGET isapnp DESTINATION reactos/system32/drivers NO_CAB FOR all)