[PCI]
[reactos.git] / drivers / bus / pci / CMakeLists.txt
index a0b3662..5917718 100644 (file)
@@ -5,9 +5,7 @@ add_library(pci SHARED
     pdo.c
     pci.rc)
 
-set_target_properties(pci PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--subsystem,native -Wl,--exclude-all-symbols" SUFFIX ".sys")
-
+set_module_type(pci kernelmodedriver)
 add_importlibs(pci ntoskrnl hal)
-add_dependencies(pci psdk bugcodes buildno_header)
-add_minicd_target(pci reactos pci.sys)
-add_livecd_target(pci reactos/system32/drivers)
\ No newline at end of file
+add_pch(pci pci.h)
+add_cd_file(TARGET pci DESTINATION reactos/system32/drivers NO_CAB FOR all)