- Sync with trunk r58248 to bring the latest changes from Amine (headers) and others...
[reactos.git] / drivers / bus / pci / CMakeLists.txt
index b27db43..5917718 100644 (file)
@@ -1,16 +1,11 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES>")
-
 add_library(pci SHARED
     fdo.c
     pci.c
     pdo.c
     pci.rc)
 
-set_target_properties(pci PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--subsystem,native" SUFFIX ".sys")
-
-target_link_libraries(pci
-    -lntoskrnl
-    -lhal)
-
-add_dependencies(pci psdk bugcodes buildno_header)
+set_module_type(pci kernelmodedriver)
+add_importlibs(pci ntoskrnl hal)
+add_pch(pci pci.h)
+add_cd_file(TARGET pci DESTINATION reactos/system32/drivers NO_CAB FOR all)