[CMAKE]
[reactos.git] / drivers / bus / pcix / CMakeLists.txt
index ed7f95f..93936ec 100644 (file)
@@ -1,6 +1,4 @@
 
-
-
 list(APPEND SOURCE
     arb/ar_busno.c
     arb/ar_memio.c
@@ -40,11 +38,9 @@ list(APPEND SOURCE
 
 add_library(pcix SHARED ${CMAKE_CURRENT_BINARY_DIR}/pcix_pci.h.gch ${SOURCE})
 
-set_target_properties(pcix PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--subsystem,native" SUFFIX ".sys")
+set_target_properties(pcix PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--subsystem,native -Wl,--exclude-all-symbols" SUFFIX ".sys")
 
-target_link_libraries(pcix
-    -lntoskrnl
-    -lhal)
+add_importlibs(pcix ntoskrnl hal)
 
 add_pch(pcix ${CMAKE_CURRENT_SOURCE_DIR}/pci.h ${SOURCE})
-add_dependencies(pcix pcix_def psdk pciclass)
+add_dependencies(pcix psdk pciclass buildno_header)