Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / drivers / bus / pcix / CMakeLists.txt
index 6553b6d..af11068 100644 (file)
@@ -36,11 +36,12 @@ list(APPEND SOURCE
     utils.c
     pci.rc)
 
-add_library(pcix SHARED ${CMAKE_CURRENT_BINARY_DIR}/pcix_pci.h.gch ${SOURCE})
-
-set_target_properties(pcix PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--subsystem,native -Wl,--exclude-all-symbols" SUFFIX ".sys")
+add_library(pcix SHARED ${SOURCE})
 
+set_module_type(pcix kernelmodedriver)
 add_importlibs(pcix ntoskrnl hal)
 
-add_pch(pcix ${CMAKE_CURRENT_SOURCE_DIR}/pci.h ${SOURCE})
-add_dependencies(pcix pcix_def psdk pciclass buildno_header)
+add_pch(pcix pci.h)
+add_dependencies(pcix pciclass)
+
+add_cd_file(TARGET pcix DESTINATION reactos/system32/drivers NO_CAB FOR all)