Sync with trunk r58740.
[reactos.git] / drivers / bus / pcix / CMakeLists.txt
index ed7f95f..af11068 100644 (file)
@@ -1,6 +1,4 @@
 
-
-
 list(APPEND SOURCE
     arb/ar_busno.c
     arb/ar_memio.c
@@ -38,13 +36,12 @@ list(APPEND SOURCE
     utils.c
     pci.rc)
 
-add_library(pcix SHARED ${CMAKE_CURRENT_BINARY_DIR}/pcix_pci.h.gch ${SOURCE})
+add_library(pcix SHARED ${SOURCE})
 
-set_target_properties(pcix PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--subsystem,native" SUFFIX ".sys")
+set_module_type(pcix kernelmodedriver)
+add_importlibs(pcix ntoskrnl hal)
 
-target_link_libraries(pcix
-    -lntoskrnl
-    -lhal)
+add_pch(pcix pci.h)
+add_dependencies(pcix pciclass)
 
-add_pch(pcix ${CMAKE_CURRENT_SOURCE_DIR}/pci.h ${SOURCE})
-add_dependencies(pcix pcix_def psdk pciclass)
+add_cd_file(TARGET pcix DESTINATION reactos/system32/drivers NO_CAB FOR all)