[CMAKE]
[reactos.git] / drivers / filesystems / cdfs / CMakeLists.txt
index 0ed1202..ebc4bd6 100644 (file)
@@ -1,5 +1,5 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES>")
+
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/drivers)
 
@@ -9,6 +9,7 @@ list(APPEND SOURCE
     close.c
     common.c
     create.c
+    devctrl.c
     dirctl.c
     fcb.c
     finfo.c
@@ -28,3 +29,5 @@ target_link_libraries(cdfs
 
 add_pch(cdfs ${CMAKE_CURRENT_SOURCE_DIR}/cdfs.h ${SOURCE})
 add_dependencies(cdfs psdk bugcodes)
+add_minicd_target(cdfs reactos cdfs.sys)
+add_livecd_target(cdfs reactos/system32/drivers cdfs.sys)
\ No newline at end of file