- Update to r53061
[reactos.git] / drivers / filesystems / ext2 / CMakeLists.txt
index 621aa02..46375e4 100644 (file)
@@ -1,3 +1,4 @@
+
 include_directories(inc)
 
 list(APPEND SOURCE
@@ -22,13 +23,9 @@ list(APPEND SOURCE
     
 add_library(ext2fs SHARED ${SOURCE})
 
-set_target_properties(ext2fs PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--exclude-all-symbols -Wl,--subsystem,native" SUFFIX ".sys")
-
-
-target_link_libraries(ext2fs
-    -lntoskrnl
-    -lhal)
+target_link_libraries(ext2fs ${PSEH_LIB})
+add_pch(ext2fs inc/ext2fsd.h)
+set_module_type(ext2fs kernelmodedriver)
+add_importlibs(ext2fs ntoskrnl hal)
 
-add_dependencies(ext2fs psdk bugcodes)
-add_minicd_target(ext2fs reactos ext2.sys)
-add_livecd_target(ext2fs reactos/system32/drivers ext2.sys)
\ No newline at end of file
+add_cd_file(TARGET ext2fs DESTINATION reactos/system32/drivers NO_CAB FOR all)