- Update to r53061
[reactos.git] / drivers / filesystems / fastfat / CMakeLists.txt
index 681069b..af6a263 100644 (file)
@@ -1,6 +1,4 @@
 
-
-
 list(APPEND SOURCE
     blockdev.c
     cleanup.c
@@ -25,13 +23,11 @@ list(APPEND SOURCE
     volume.c
     vfatfs.rc)
 
-add_library(fastfat SHARED ${CMAKE_CURRENT_BINARY_DIR}/fastfat_vfat.h.gch ${SOURCE})
+add_library(fastfat SHARED ${SOURCE})
 
-set_target_properties(fastfat PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--exclude-all-symbols -Wl,--subsystem,native" SUFFIX ".sys")
+set_module_type(fastfat kernelmodedriver)
+add_importlibs(fastfat ntoskrnl hal)
 
-target_link_libraries(fastfat
-    -lntoskrnl
-    -lhal)
+add_pch(fastfat vfat.h)
 
-add_pch(fastfat ${CMAKE_CURRENT_SOURCE_DIR}/vfat.h ${SOURCE})
-add_dependencies(fastfat psdk bugcodes)
+add_cd_file(TARGET fastfat DESTINATION reactos/system32/drivers NO_CAB FOR all)