[CMAKE]
[reactos.git] / drivers / filesystems / mup / CMakeLists.txt
index 56f83d6..6ac375d 100644 (file)
@@ -4,7 +4,7 @@ add_library(mup SHARED
     mup.c
     mup.rc)
 
-set_target_properties(mup PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--exclude-all-symbols -Wl,--subsystem,native" SUFFIX ".sys")
-
+set_module_type(mup kernelmodedriver)
 add_importlibs(mup ntoskrnl hal)
-add_dependencies(mup psdk bugcodes)
+
+add_cd_file(TARGET mup DESTINATION reactos/system32/drivers FOR all)
\ No newline at end of file