[FASTFAT] Start implementing FAT32 statistics support
[reactos.git] / drivers / filesystems / npfs / CMakeLists.txt
index b1d4c04..ee22a31 100644 (file)
@@ -1,19 +1,31 @@
 
 list(APPEND SOURCE
+    cleanup.c
+    close.c
     create.c
-    dirctl.c
-    finfo.c
+    datasup.c
+    fileinfo.c
+    fileobsup.c
+    flushbuf.c
     fsctrl.c
-    npfs.c
-    rw.c
-    volume.c
-    npfs.rc)
-
-add_library(npfs SHARED ${SOURCE})
-
-target_link_libraries(npfs ${PSEH_LIB})
+    main.c
+    prefxsup.c
+    read.c
+    readsup.c
+    secursup.c
+    seinfo.c
+    statesup.c
+    strucsup.c
+    volinfo.c
+    waitsup.c
+    write.c
+    writesup.c
+    npfs.h)
 
+add_library(npfs SHARED ${SOURCE} npfs.rc)
 set_module_type(npfs kernelmodedriver)
+target_link_libraries(npfs ${PSEH_LIB})
 add_importlibs(npfs ntoskrnl hal)
-add_pch(npfs npfs.h)
+add_pch(npfs npfs.h SOURCE)
 add_cd_file(TARGET npfs DESTINATION reactos/system32/drivers FOR all)
+add_registry_inf(npfs_reg.inf)