[SETUP] Remove FSDs which have broken dismount implementation.
[reactos.git] / drivers / filesystems / ntfs / CMakeLists.txt
index 172436e..5a193b4 100644 (file)
@@ -2,8 +2,11 @@
 list(APPEND SOURCE
     attrib.c
     blockdev.c
+    btree.c
+    cleanup.c
     close.c
     create.c
+    devctl.c
     dirctl.c
     dispatch.c
     fastio.c
@@ -15,13 +18,11 @@ list(APPEND SOURCE
     ntfs.c
     rw.c
     volinfo.c
-    ntfs.rc)
-    
-add_library(ntfs SHARED ${SOURCE})
+    ntfs.h)
 
+add_library(ntfs SHARED ${SOURCE} ntfs.rc)
 set_module_type(ntfs kernelmodedriver)
+target_link_libraries(ntfs ${PSEH_LIB})
 add_importlibs(ntfs ntoskrnl hal)
-
-add_pch(ntfs ntfs.h)
-
-add_cd_file(TARGET ntfs DESTINATION reactos/system32/drivers NO_CAB FOR all)
+add_pch(ntfs ntfs.h SOURCE)
+add_cd_file(TARGET ntfs DESTINATION reactos/system32/drivers FOR all)