[NTFS] - In the NtfsAddFilenameToDirectory() function, rename DirectoryContext parame...
[reactos.git] / drivers / filesystems / ntfs / CMakeLists.txt
index ed4875f..ff3b35f 100644 (file)
@@ -2,8 +2,10 @@
 list(APPEND SOURCE
     attrib.c
     blockdev.c
+    cleanup.c
     close.c
     create.c
+    devctl.c
     dirctl.c
     dispatch.c
     fastio.c
@@ -18,10 +20,8 @@ list(APPEND SOURCE
     ntfs.h)
 
 add_library(ntfs SHARED ${SOURCE} ntfs.rc)
-
 set_module_type(ntfs kernelmodedriver)
+target_link_libraries(ntfs ${PSEH_LIB})
 add_importlibs(ntfs ntoskrnl hal)
-
 add_pch(ntfs ntfs.h SOURCE)
-
 add_cd_file(TARGET ntfs DESTINATION reactos/system32/drivers NO_CAB FOR all)