[ACLEDIT][ATL][ATL80][FLTMGR] Get the def files out of the source files lists. #179
[reactos.git] / drivers / filters / fltmgr / CMakeLists.txt
index cb6ebbd..8519974 100644 (file)
@@ -1,3 +1,10 @@
+
+include_directories(
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/drivers/fltmgr
+    includes)
+
+spec2def(fltmgr.sys fltmgr.spec ADD_IMPORTLIB)
+
 list(APPEND SOURCE
     Context.c
     Dispatch.c
@@ -9,18 +16,12 @@ list(APPEND SOURCE
     Object.c
     Registry.c
     Volume.c
-    ${CMAKE_CURRENT_BINARY_DIR}/fltmgr.def
     fltmgr.h)
 
-include_directories(
-    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/drivers/fltmgr
-    includes)
-
-spec2def(fltmgr.sys fltmgr.spec ADD_IMPORTLIB)
-
 add_library(fltmgr SHARED
     ${SOURCE}
-    fltmgr.rc)
+    fltmgr.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/fltmgr.def)
 
 set_module_type(fltmgr kernelmodedriver)
 target_link_libraries(fltmgr ${PSEH_LIB})