Sync with trunk r63270.
[reactos.git] / drivers / hid / hidclass / CMakeLists.txt
index f5f6922..93a1b68 100644 (file)
@@ -1,14 +1,17 @@
 
-spec2def(hidclass.sys hidclass.spec)
+spec2def(hidclass.sys hidclass.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     fdo.c
     hidclass.c
-    hidclass.rc
     pdo.c
-    ${CMAKE_CURRENT_BINARY_DIR}/hidclass.def)
+    precomp.h)
 
-add_library(hidclass SHARED ${SOURCE})
+add_library(hidclass SHARED
+    ${SOURCE}
+    guid.c
+    hidclass.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/hidclass.def)
 
 set_entrypoint(hidclass 0)
 set_subsystem(hidclass native)
@@ -16,6 +19,6 @@ set_target_properties(hidclass PROPERTIES SUFFIX ".sys")
 
 
 add_importlibs(hidclass ntoskrnl hidparse hal)
-add_importlib_target(hidclass.spec)
-
-add_cd_file(TARGET hidclass DESTINATION reactos/system32/drivers NO_CAB FOR all)
\ No newline at end of file
+add_dependencies(hidclass bugcodes)
+add_pch(hidclass precomp.h SOURCE)
+add_cd_file(TARGET hidclass DESTINATION reactos/system32/drivers NO_CAB FOR all)