[I8042PRT] Move DMI/SMBIOS parsing functions into library
[reactos.git] / drivers / input / i8042prt / CMakeLists.txt
index ecf91a1..808367f 100644 (file)
@@ -1,8 +1,10 @@
 
-set_rc_compiler()
+include_directories(
+    ${REACTOS_SOURCE_DIR}/sdk/lib/dmilib)
 
-add_library(i8042prt SHARED
+list(APPEND SOURCE
     createclose.c
+    hwhacks.c
     i8042prt.c
     keyboard.c
     misc.c
@@ -11,9 +13,15 @@ add_library(i8042prt SHARED
     ps2pp.c
     readwrite.c
     registry.c
+    i8042prt.h)
+
+add_library(i8042prt SHARED
+    ${SOURCE}
+    guid.c
     i8042prt.rc)
 
 set_module_type(i8042prt kernelmodedriver)
+target_link_libraries(i8042prt dmilib)
 add_importlibs(i8042prt ntoskrnl hal)
-add_pch(i8042prt i8042prt.h)
-add_cd_file(TARGET i8042prt DESTINATION reactos/system32/drivers NO_CAB FOR all)
\ No newline at end of file
+add_pch(i8042prt i8042prt.h SOURCE)
+add_cd_file(TARGET i8042prt DESTINATION reactos/system32/drivers NO_CAB FOR all)