Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / drivers / input / kbdclass / CMakeLists.txt
diff --git a/drivers/input/kbdclass/CMakeLists.txt b/drivers/input/kbdclass/CMakeLists.txt
new file mode 100644 (file)
index 0000000..326915a
--- /dev/null
@@ -0,0 +1,17 @@
+
+list(APPEND SOURCE
+    kbdclass.c
+    misc.c
+    kbdclass.h)
+
+add_library(kbdclass SHARED
+    ${SOURCE}
+    guid.c
+    kbdclass.rc)
+
+set_module_type(kbdclass kernelmodedriver)
+add_pch(kbdclass kbdclass.h SOURCE)
+target_link_libraries(kbdclass ${PSEH_LIB})
+add_importlibs(kbdclass ntoskrnl hal)
+add_cd_file(TARGET kbdclass DESTINATION reactos/system32/drivers NO_CAB FOR all)
+add_registry_inf(kbdclass_reg.inf)