* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / drivers / input / sermouse / CMakeLists.txt
index 42dfee9..b2cd5da 100644 (file)
@@ -1,5 +1,5 @@
 
-add_library(sermouse SHARED
+list(APPEND SOURCE
     createclose.c
     detect.c
     fdo.c
@@ -7,9 +7,10 @@ add_library(sermouse SHARED
     misc.c
     readmouse.c
     sermouse.c
-    sermouse.rc)
+    sermouse.h)
 
+add_library(sermouse SHARED ${SOURCE} sermouse.rc)
 set_module_type(sermouse kernelmodedriver)
-add_pch(sermouse sermouse.h)
+add_pch(sermouse sermouse.h SOURCE)
 add_importlibs(sermouse ntoskrnl hal)
 add_cd_file(TARGET sermouse DESTINATION reactos/system32/drivers FOR all)