[CMAKE]
[reactos.git] / drivers / network / dd / pcnet / CMakeLists.txt
index a73b26c..b42819e 100644 (file)
@@ -1,8 +1,9 @@
 
-add_definitions(-DNDIS50_MINIPORT)
-add_definitions(-DNDIS_MINIPORT_DRIVER)
-add_definitions(-DNDIS_LEGACY_MINIPORT)
-add_definitions(-DNDIS51_MINIPORT)
+add_definitions(
+    -DNDIS50_MINIPORT
+    -DNDIS_MINIPORT_DRIVER
+    -DNDIS_LEGACY_MINIPORT
+    -DNDIS51_MINIPORT)
 
 list(APPEND SOURCE
     pcnet.c
@@ -12,12 +13,6 @@ list(APPEND SOURCE
 add_library(pcnet SHARED ${SOURCE})
 
 set_module_type(pcnet kernelmodedriver)
+add_importlibs(pcnet ndis ntoskrnl hal)
 
-target_link_libraries(pcnet
-    -lndis
-    -lntoskrnl
-    -lhal)
-
-add_dependencies(pcnet psdk bugcodes buildno_header)
-
-add_cab_target(pcnet 2)
\ No newline at end of file
+add_cab_target(pcnet 2)