[BLUE] Perform size/rectangle boundary checks on read/write operations. CORE-15108
[reactos.git] / drivers / network / ndis / CMakeLists.txt
index 3a81a64..f338362 100644 (file)
@@ -1,5 +1,6 @@
 
 include_directories(BEFORE include)
+spec2def(ndis.sys ndis.spec ADD_IMPORTLIB)
 
 add_definitions(
     -DNDIS_WRAPPER
@@ -10,8 +11,6 @@ add_definitions(
     -DNDIS_LEGACY_PROTOCOL
     -DNDIS_MINIPORT_DRIVER)
 
-spec2def(ndis.sys ndis.spec ADD_IMPORTLIB)
-
 list(APPEND SOURCE
     ndis/30stubs.c
     ndis/40stubs.c
@@ -41,8 +40,5 @@ add_library(ndis SHARED
 
 set_module_type(ndis kernelmodedriver)
 add_importlibs(ndis ntoskrnl hal)
-
 add_pch(ndis include/ndissys.h SOURCE)
-
 add_cd_file(TARGET ndis DESTINATION reactos/system32/drivers FOR all)
-