[CMAKE]
[reactos.git] / drivers / setup / blue / CMakeLists.txt
index f11b3a6..ae3c8f6 100644 (file)
@@ -1,14 +1,9 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES>")
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/drivers)
 
 add_library(blue SHARED blue.c font.c blue.rc)
 
-set_target_properties(blue PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--exclude-all-symbols -Wl,--subsystem,native" SUFFIX ".sys")
-
-target_link_libraries(blue
-    -lntoskrnl
-    -lhal)
+set_module_type(blue kernelmodedriver)
+add_importlibs(blue ntoskrnl hal)
 
-add_dependencies(blue psdk bugcodes)
+add_cd_file(TARGET blue DESTINATION reactos/system32/drivers NO_CAB FOR all)