Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / drivers / storage / ide / uniata / CMakeLists.txt
index 00128c2..c201645 100644 (file)
@@ -1,12 +1,12 @@
 
+set_cpp()
+
 include_directories(
     BEFORE ${CMAKE_CURRENT_SOURCE_DIR}
     inc)
 
 #add_definitions(-D_DEBUG)
 
-set_cpp()
-
 list(APPEND SOURCE
     id_ata.cpp
     id_badblock.cpp
@@ -19,14 +19,11 @@ list(APPEND SOURCE
 
 add_library(uniata SHARED ${SOURCE} idedma.rc)
 
-# FIXME: http://www.cmake.org/Bug/view.php?id=12998
-if(MSVC)
-    #add_target_compile_flags(uniata "/GR-")
-    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "/GR-")
-else()
+
+if(NOT MSVC)
+    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
     #allow_warnings(uniata)
-    #add_target_compile_flags(uniata "-fno-exceptions -fno-rtti")
-    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-fno-exceptions -fno-rtti -Wno-error")
+    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-error -Wno-unused-but-set-variable -Wno-narrowing")
 endif()
 
 add_pch(uniata stdafx.h)