- Fixed CMakeLists issues reported by hbelusca
[reactos.git] / drivers / storage / storahci / CMakeLists.txt
index 0f09d56..039ed8d 100644 (file)
@@ -1,27 +1,10 @@
-
-set_cpp()
-
-include_directories(
-    BEFORE ${CMAKE_CURRENT_SOURCE_DIR}
-    inc)
-
-#add_definitions(-DDEBUG)
+add_definitions(-DDEBUG)
 
 list(APPEND SOURCE
-    storahci.cpp
-    ros_glue/ros_glue.cpp
-    stdafx.h)
+    storahci.c)
 
 add_library(storahci SHARED ${SOURCE} storahci.rc)
 
-if(NOT MSVC)
-    add_target_compile_flags(storahci "-Wno-narrowing")
-    if(NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
-        add_target_compile_flags(storahci "-Wno-unused-but-set-variable")
-    endif()
-endif()
-
-add_pch(storahci stdafx.h SOURCE)
 set_module_type(storahci kernelmodedriver)
 add_importlibs(storahci storport ntoskrnl hal)
 add_cd_file(TARGET storahci DESTINATION reactos/system32/drivers NO_CAB FOR all)